JAVA Sending Email via Outlook with SWT

I used Java 1.6 in x86 to send emails via opening Outlook and send email, all commands with SWT. source
Everithing works really fine, but recently my job decide to change the operation system to x64 and the version of Outlook (2010 to 2016), but for some reasons, the Java decide to keep the 1.6
With all of this my code stop to work. Even, when i try to update SWT (1.5 to 1.8) it sends me the message:

java.lang.UnsupportedClassVersionError: org/eclipse/swt/widgets/Composite : Unsupported major.minor version 52.0

So after of research i found the next things:

    If you update the version of SWT, in x86, everithing stop to working for the error that i said before
    Even, if you keep the version of SWT (1.5) the mail doesnt open in x64

The questions are

There’s a way to update the email code to works in x64?

There’s a way to update the library from 1.5 to 1.8 and works in x64 (even un x86)?

And as i said it before, i cant update the java version (some weird security reasons bigger than me)